import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=cardNo\\\"?\\s?:\\s?\\\"\\d{0,100})\\d(?!\\d{0,3}\\\")";
final String string = "cardNo\":\"10929291929312911131\"\n"
+ "(cardNo:\"10929291929312911131\",cardType:\"CREDIT\")\n"
+ "\"cardNo\" : \"10929291929312911131\" \n"
+ "creditCardData(cardNo: \"10929291929312911131\",cardType:\"CREDIT\") –";
final String subst = "X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}