#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))"
Local $sString = "32.0.0.142" & @CRLF & _
"32.0.0.171" & @CRLF & _
"32.0.0.156" & @CRLF & _
"31." & @CRLF & _
"29" & @CRLF & _
"32" & @CRLF & _
"30."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")