const regex = /^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-2]|3[0-1]|32.0.0.([0-1][0-6]|170))', 'gm')
const str = `32.0.0.142
32.0.0.171
32.0.0.156
31.
29
32
30.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}