re = /(\w+\[)(\w+(\[(?:[^][|]++|(?3))*])?(?:\s*\|\s*\w+(\[(?:[^][|]++|(?4))*])?)+)]/m
str = 'str|int|bool
Optional[int|tuple[str|int]]
dict[str | int, list[B | C | Optional[D]]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end