package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:\s*\|\s*\w+)+`)
var str = `str|int|bool
Optional[int|tuple[str|int]]
dict[str | int, list[B | C | Optional[D]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}