$re = '/\(\s+(.*?)\s+\)/m';
$str = 'foo( a )';
$subst = "($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;