using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\d+(?:,\d+)+]";
string input = @"[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]
[123]
[123,1,2,34]
[123,1,2]
[]
[1,,2]
[,1,2]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}