package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)digits-range-(\d+)-(\d+)?$`)
var str = `digits-range-1-10000
digits-range-2-
digits-range-1-10000-234
digits-range-1.5-2.5
diginge-1-10000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}