import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<= [+][1-9])|(?<= [1-9])|(?<= ))([2-9][0-9]{9})\\b";
final String string = "abcd +12125551212 xyz should match starting at 212 \n"
+ "abcd +2125551212 xyz should NOT match (+ sign only)\n"
+ "abcd 2125551212 xyz match OK!\n"
+ "abcd+12125551212 xyz should NOT match (no white space at start)\n"
+ "abcd 12125551212 xyz should match starting at 212\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}