use strict;
my $str = '<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_1"> Лев Сорокин says:</a></div> ÑброÑить пароль <a href="#user_4">Тимур Данилов</a> в <a href="#supplier_1">ООО Ромашка</a></blockquote>
СброÑил
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_2"> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>
Ок =)
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_4"> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_5">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>';
my $regex = qr/(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=["']([^\'\"]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}