# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=[\"']([^\'\"]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)"
test_str = ("<blockquote class=\"bs-callout bs-callout-info comment\"><div class=\"author\"><a class=\"comm_link\" href=\"#comment_1\"> Лев Сорокин says:</a></div> ÑброÑить пароль <a href=\"#user_4\">Тимур Данилов</a> в <a href=\"#supplier_1\">ООО Ромашка</a></blockquote>\n"
"СброÑил\n"
"<blockquote class=\"bs-callout bs-callout-info comment\"><div class=\"author\"><a class=\"comm_link\" href=\"#comment_2\"> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>\n"
"Ок =)\n"
"<blockquote class=\"bs-callout bs-callout-info comment\"><div class=\"author\"><a class=\"comm_link\" href=\"#comment_4\"> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class=\"bs-callout bs-callout-info comment\"><div class=\"author\"><a class=\"comm_link\" href=\"#comment_5\">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.