import Foundation
let pattern = #"(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=["']([^\'\"]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_1"> Лев Сорокин says:</a></div> ÑброÑить пароль <a href="#user_4">Тимур Данилов</a> в <a href="#supplier_1">ООО Ромашка</a></blockquote>
СброÑил
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_2"> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>
Ок =)
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_4"> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_5">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)