const regex = /[^A-Z]+|(?:(?=[A-Za-z]*[a-z])\b[A-Za-z]+\b)|(?:\b[A-Z]+\b(?=[^a-z]+[A-Z])(?:[^a-z]*\b[A-Z]+\b)*\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^A-Z]+|(?:(?=[A-Za-z]*[a-z])\\b[A-Za-z]+\\b)|(?:\\b[A-Z]+\\b(?=[^a-z]+[A-Z])(?:[^a-z]*\\b[A-Z]+\\b)*\\b)', 'g')
const str = `This is a sentence WITH some capitalised WORDS
IN it AS well as
MULTILINING
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}