re = /[^A-Z]+|(?:(?=[A-Za-z]*[a-z])\b[A-Za-z]+\b)|(?:\b[A-Z]+\b(?=[^a-z]+[A-Z])(?:[^a-z]*\b[A-Z]+\b)*\b)/
str = 'This is a sentence WITH some capitalised WORDS
IN it AS well as
MULTILINING
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end