#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[\da-fA-F]{2}[\s:.-]?){6})"
Local $sString = "Entry Mac Vlan INTF PORT MOD MPLS_LABEL ToCpu Drop RefCount" & @CRLF & _
"100002 00:00:00:00:00:00 4094 0 0 0 -1 yes no 2" & @CRLF & _
"100004 00 00 1a 0a 84 95 1 1 13 0 -1 no no 1" & @CRLF & _
"100005 a8:97:dc:8c:95:01 3 3 0t 0 -1 no no 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")