using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s(\d{1,2})e(\d{1,2})";
string input = @"S3E1 hehehe bla s09e12";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}