$re = '/s(\d{1,2})e(\d{1,2})/i';
$str = 'S3E1 hehehe bla s09e12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);