$re = '/(href="([^"]+).*(?=img src))|(img src="([^"]*))/m';
$str = '<a href="I NEED THIS1"> <img src="I NEED THIS2"> </a>
<a href="I DONT NEED THIS" title="something"> </a>
<a href="I NEED THIS3" title="blah"> <figure> <img src="I NEED THIS4" alt=""> </figure> </a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);