using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(-?\d+(?:[\.,]\d+)?)""";
string substitution = @"\1";
string input = @"""name"": ""Gnosis"", \n ""symbol"": ""GNO"", \n ""rank"": ""99"", \n ""price_usd"": ""175.029"", \n ""price_btc"": ""-0.0186887"", \n ""24h_volume_usd"": ""753877.0""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}