// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(-?\d+(?:[\.,]\d+)?)""#).unwrap();
let string = "\"name\": \"Gnosis\", \\n \"symbol\": \"GNO\", \\n \"rank\": \"99\", \\n \"price_usd\": \"175.029\", \\n \"price_btc\": \"-0.0186887\", \\n \"24h_volume_usd\": \"753877.0\"
";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}