using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)<(?:(?!br\s*>|br\s*\/>)[^>'""]*|(['""]).*?\1)*>";
string input = @"THis is a test <p>paragraph</p>Let's Jump<br>
haha It worked !!! :P<wuuut>
This BR won't be matched <BR/>
<b>That cool :)</b>
This is more reliable <br />
<a>as you can see</a><Br />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}