import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)<(?:(?!br\\s*>|br\\s*\\/>)[^>'\"]*|(['\"]).*?\\1)*>";
final String string = "THis is a test <p>paragraph</p>Let's Jump<br>\n"
+ "haha It worked !!! :P<wuuut>\n"
+ "This BR won't be matched <BR/>\n"
+ "<b>That cool :)</b>\n"
+ "This is more reliable <br />\n"
+ "<a>as you can see</a><Br />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}