re = /^([0-9a-f]+)_(string[^_]+)_(string[^_]+)_(string[^_]+)_([0-9]+)_([0-9]+)_([^_]+)$/mix
str = '10E4558AA0_String1_String2_String3_0_100_12mo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end