#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+@.+(\.|:).+"
Local $sString = "ß@ê.∆" & @CRLF & _
"hello@haroen.me" & @CRLF & _
"test@127.0.0.1" & @CRLF & _
"k@::1" & @CRLF & _
"test@localhost" & @CRLF & _
"test@something.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")