#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^[A-Z]"
Local $sString = ""R$ 2,010,000,020.00""
Local $sSubst = "B"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)