import Foundation
let pattern = #"^[A-Z]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""R$ 2,010,000,020.00""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"B"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)