#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\w]+"
Local $sString = "program p;" & @CRLF & _
"begin" & @CRLF & _
" write('x');" & @CRLF & _
"end."
Local $sSubst = "X"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)