#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span(?!.*? id="textmarker).*?">"
Local $sString = "<p style="font-size: inherit; display: block; margin-bottom: 1em; margin-top: 0px;">It’s worth elaborating on the latter point. There are all sorts of things it would be morally good to do, but that would involve such great personal sacrifice that nobody could reasonably<span class="Apple-converted-space"> </span>expect<span class="Apple-converted-space"> </span>it (of others or of themselves).<span class="Apple-converted-space"> </span><span id="textmarker_14">Donating half your income to the most<span class="Apple-converted-space"> </span></span><span><span id="textmarker_15">cost-effective charities</span></span><span id="textmarker_16" class="textmarker textmarker_8">, as some in the Effective Altruism movement recommend, would be morally outstanding</span>.</p>" & @CRLF & _
"<p style="font-size: inherit; display: block; margin-bottom: 1em; margin-top: 0px;">This sort of ‘demandingness constraint’ on plausible moral obligations seems all the stronger when it comes to procreative ethics. It’s one thing to ask us to give up a large portion of our salaries. But it would be still<span class="Apple-converted-space"> </span><em>more</em><span class="Apple-converted-space"> </span>demanding and intrusive to ask that an otherwise fortunately situated woman effectively give up her entire life and autonomy to become a living, breathing baby factory. Even if it would bring about the most impartial good (which doesn’t seem very likely in any case – there might always be better things she could achieve with her life), such a huge personal sacrifice is simply<em>way too much to ask</em><span class="Apple-converted-space"> </span>of anyone. So we can reasonably reject the proposed procreative obligation on that basis.</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")