import re
regex = re.compile(r"[\u4e00-\u9fa5]{3,}(第一|质量|最)[\u4e00-\u9fa5]{3,}", flags=re.MULTILINE)
test_str = "我国依然是世界上第一人口的国家;中国制造的产品质量依然是....根据数据分析得到的数据结果是最准确的!"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")