re = /[\u4e00-\u9fa5]{3,}(第一|质量|最)[\u4e00-\u9fa5]{3,}/m
str = '我国依然是世界上第一人口的国家;中国制造的产品质量依然是....根据数据分析得到的数据结果是最准确的!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end