// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\u4e00-\u9fa5]{3,}(第一|质量|最)[\u4e00-\u9fa5]{3,}").unwrap();
let string = "我国依然是世界上第一人口的国家;中国制造的产品质量依然是....根据数据分析得到的数据结果是最准确的!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}