#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)@[^{]+{(?>[^{}]+ | (?R))+?}"
Local $sString = "@font-face" & @CRLF & _
" {" & @CRLF & _
" font-family: Gloria script;" & @CRLF & _
" " & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".header li {" & @CRLF & _
" width: auto;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@media( max-width: 470px ) {" & @CRLF & _
" .clbar {" & @CRLF & _
" position: static;" & @CRLF & _
" right: auto;" & @CRLF & _
" top: auto;" & @CRLF & _
"" & @CRLF & _
" }" & @CRLF & _
" .clent {" & @CRLF & _
" margin: 30px 0 10px;" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")