using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@[^{]+{(?>[^{}]+ | (?R))+?}";
string input = @"@font-face
{
font-family: Gloria script;
}
.header li {
width: auto;
}
@media( max-width: 470px ) {
.clbar {
position: static;
right: auto;
top: auto;
}
.clent {
margin: 30px 0 10px;
}
}";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}