$re = '/(@.*^})/sUm';
$str = '@font-face
{
font-family: Gloria script;
}
.header li {
width: auto;
}
@media( max-width: 470px ) {
.clbar {
position: static;
right: auto;
top: auto;
}
.clent {
margin: 30px 0 10px;
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);