import Foundation
let pattern = #"(\[a\])([^\[]+)(\[\/a\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='$2'>$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)