Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)
/
Input 1
1
New
Spring.GetVectorFromHeading ( number heading ,test value) -> ReturnType ReturnName converted into $Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end