import Foundation
let pattern = #"(?P<Spring>Spring\.)(?P<FunctionName>[a-zA-Z0-9]+)([^\(]+\()(?P<Arguments>([^\)]+))\)([^>]+>)(?P<ReturnType>[^\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Spring.GetVectorFromHeading
( number heading ,test value)
-> ReturnType ReturnName
converted into
$Spring$FunctionName = function $FunctionName($Arguments) assert($Arguments); return $ReturnType end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}