$re = '/http://v\.youku\.com/v_show/id_(\w+)\.html/';
$str = 'http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;