# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?=\(\+)\()|[\s+=]|((?<=M)\))"
test_str = ("C5H6 + O = NC4H5 + CO + H\n\n"
"C5H5 + H (+M)= C5H6 (+M)\n\n"
"C5H5 + HO2 = C5H5O(2,4) + OH\n\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.