re = /((?=\(\+)\()|[\s+=]|((?<=M)\))/
str = 'C5H6 + O = NC4H5 + CO + H
C5H5 + H (+M)= C5H6 (+M)
C5H5 + HO2 = C5H5O(2,4) + OH
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result