using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^>=]|='[^']*'|=""[^""]*""|=[^'""][^\s>]*)*?\s*\Konclick\s*=(['""]?)(.*?)\1(?:\s|$)";
string input = @"onclick ='unSelAll(""FBtest11_6"",this.value,this.id)'
onmouseover="" onclick ='This is not the droid you are looking for' "" onclick =""find me instead""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}