# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[\s\S].*?)(?<=area\\/)([^-])([^-]*)(-)([^\\/])([^\\/]*).*/\/\U$1\E$2$3\U$4\E$5\//gm;t' <<< "abc/123/area/my-folder/state/..."