// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^([0-9-_.,:; +<>#´`"?!§°\\*()%$\/&=|Ø]{1,})$|^([0-9.,k]{1,})$|^([0-9 .,|\-]{1,}?°C)*$|^([0-9 .,|\-"\/]{1,}?x?)*$"#).unwrap();
let string = "asss
334445
33sas323
sxs23344s
dd34444
5555003234\\_323
233-444
233_444
33-.444
22 2334
33+3-322
-310 23
°10
10%
222/223
334%22
22&222
210=10
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}