$re = '/([^\s,;]+),com\b/m';
$str = 'abc,com;def,med;ghi,com;jkl,med';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);