using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\n\n)(^TY)";
string substitution = @"\n$1";
string input = @"ER - lorem ipsum
TY - JOUR
CA - Berlin
TY - BOOK
CA - New York";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}