#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)RTL_433toMQTT\/([^\/:]+)\/?:.* "
Local $sString = "rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/Generic-Motion:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/LaCrosse-TX141THBv2/0/168:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/0:.* { json2nameValue($EVENT) }" & @CRLF & _
"rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/128:.* { json2nameValue($EVENT) }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")