using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RTL_433toMQTT\/([^\/:]+)\/?:.* ";
string input = @"rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Generic-Motion:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/LaCrosse-TX141THBv2/0/168:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/0:.* { json2nameValue($EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/128:.* { json2nameValue($EVENT) }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}