import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "RTL_433toMQTT\\/([^\\/:]+)\\/?:.* ";
final String string = "rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/Generic-Motion:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/LaCrosse-TX141THBv2/0/168:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/0:.* { json2nameValue($EVENT) }\n"
+ "rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/128:.* { json2nameValue($EVENT) }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}