const regex = /RTL_433toMQTT\/([^\/:]+)\/?:.* /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('RTL_433toMQTT\\\/([^\\\/:]+)\\\/?:.* ', 'gm')
const str = `rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Generic-Motion:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/LaCrosse-TX141THBv2/0/168:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/0:.* { json2nameValue(\$EVENT) }
rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/128:.* { json2nameValue(\$EVENT) }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}