import re
regex = re.compile(r"RTL_433toMQTT\/([^\/:]+)\/?:.* ", flags=re.MULTILINE)
test_str = ("rtl433:home/rtl433/RTL_433toMQTT/Rubicson-Temperature/1/244:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/Nexus-TH/1/9:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/WT450-TH/1/1:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/Secplus-v1/0:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/Interlogix-Security/motion/485865:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/Generic-Motion:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/LaCrosse-TX141THBv2/0/168:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/0:.* { json2nameValue($EVENT) }\n"
"rtl433:home/rtl433/RTL_433toMQTT/Acurite-609TXC/128:.* { json2nameValue($EVENT) }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")